log_file.txt

download

20 lgp_suffix=yes
lgp_sign=yes
lgp_build_distrib=jessie<br/>10 Running lgp build -v -s yes -r /tmp/tmpFq9KH9/src/3597443/.. -d jessie --suffix ~revf64645f01b93<br/>10 use setup package class format: PackageInfo<br/>10 guessing distribution(s): jessie<br/>10 run subprocess command: python setup.py --name<br/>10 run subprocess command: python setup.py --version<br/>10 retrieve debian version from debian/changelog: 0.2.1-1<br/>20 create pristine tarball from working directory<br/>10 run subprocess command: python setup.py -q sdist -d /tmp/tmp95eTrF<br/>10 command substitutions: {&#39;dist_dir&#39;: &#39;/tmp/tmp95eTrF&#39;}<br/>20 Attempting to build jessie<br/>10 Going back to /tmp/tmpFq9KH9/src/3597443<br/>10 copy pristine tarball to prepare Debian source package diff<br/>10 extracting original source archive for jessie distribution in /tmp/tmpkWXpdZ<br/>10 suffix &#39;~revf64645f01b93&#39; added to package version<br/>20 Debian source package (format: 1.0) for &#39;jessie&#39;<br/>10 running dpkg-source command: dpkg-source --no-copy -b /tmp/tmpkWXpdZ/cubicweb-mediaplayer-0.2.1 ...<br/>20 create Debian source package files (.dsc, .diff.gz): cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.dsc<br/>20 this build is arch-independent. Lgp will only build on architecture amd64<br/>10 changing build context... (/tmp/tmp7mafEt)<br/>10 package builder flavour: &#39;pbuilder&#39;<br/>20 building binary debian package for &#39;jessie/amd64&#39; using DEBBUILDOPTS options: &#39;(none)&#39; ...<br/>10 running build command: sudo IMAGE=/var/cache/lgp/buildd/jessie-amd64.tgz DIST=jessie ARCH=amd64 pbuilder build --configfile /etc/lgp/pbuilderrc --buildresult /tmp/tmp7mafEt --hookdir /var/lib/logilab-packaging/hooks /tmp/tmpkWXpdZ/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.dsc ...<br/>50 binary build(s) failed for &#39;jessie&#39; with exit status 1<br/>20 a build logfile is available: /tmp/tmpFq9KH9/src/jessie/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93_amd64_jessie.lgp-build.log<br/>20 recent files from build:
* /tmp/tmpFq9KH9/src/jessie/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93_amd64_jessie.lgp-build.log<br/>20 begin scanning for log files <br/>20 printing /tmp/tmpFq9KH9/src/3597443/../jessie/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93_amd64_jessie.lgp-build.log: I: Using pkgname logfile

I: Current time: Thu Apr 14 18:29:54 CEST 2016

I: pbuilder-time-stamp: 1460651394

I: Obtaining the cached apt archive contents

I: Installing the build-deps

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D10tmp starting

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D10tmp finished

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D50debconf starting

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D50debconf finished

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D99apt starting

+ apt-get update

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/D99apt finished

-&gt; Attempting to satisfy build-dependencies

-&gt; Creating pbuilder-satisfydepends-dummy package

Package: pbuilder-satisfydepends-dummy

Version: 0.invalid.0

Architecture: amd64

Maintainer: Debian Pbuilder Team &lt;pbuilder-maint@lists.alioth.debian.org&gt;

Description: Dummy package to satisfy dependencies with aptitude - created by pbuilder

This package was created automatically by pbuilder to satisfy the

build-dependencies of the package being currently built.

Depends: debhelper (&gt;= 9), python (&gt;= 2.6.6-3~), dh-python, python-unittest2

dpkg-deb: building package `pbuilder-satisfydepends-dummy&#39; in `/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb&#39;.

Selecting previously unselected package pbuilder-satisfydepends-dummy.

(Reading database ... 12579 files and directories currently installed.)

Preparing to unpack .../pbuilder-satisfydepends-dummy.deb ...

Unpacking pbuilder-satisfydepends-dummy (0.invalid.0) ...

dpkg: pbuilder-satisfydepends-dummy: dependency problems, but configuring anyway as you requested:

pbuilder-satisfydepends-dummy depends on debhelper (&gt;= 9); however:

Package debhelper is not installed.

pbuilder-satisfydepends-dummy depends on python (&gt;= 2.6.6-3~); however:

Package python is not installed.

pbuilder-satisfydepends-dummy depends on dh-python; however:

Package dh-python is not installed.

pbuilder-satisfydepends-dummy depends on python-unittest2; however:

Package python-unittest2 is not installed.

Setting up pbuilder-satisfydepends-dummy (0.invalid.0) ...

Reading package lists...

Building dependency tree...

Reading state information...

Initializing package states...

Writing extended state information...

Building tag database...

The following NEW packages will be installed:

bsdmainutils{a} debhelper{a} dh-python{a} file{a} gettext{a}

gettext-base{a} groff-base{a} intltool-debian{a} libasprintf0c2{a}

libcroco3{a} libexpat1{a} libglib2.0-0{a} libmagic1{a} libmpdec2{a}

libpipeline1{a} libpython-stdlib{a} libpython2.7-minimal{a}

libpython2.7-stdlib{a} libpython3-stdlib{a} libpython3.4-minimal{a}

libpython3.4-stdlib{a} libunistring0{a} libxml2{a} man-db{a}

mime-support{a} po-debconf{a} python{a} python-minimal{a}

python-support{a} python-unittest2{a} python2.7{a} python2.7-minimal{a}

python3{a} python3-minimal{a} python3.4{a} python3.4-minimal{a}

0 packages upgraded, 36 newly installed, 0 to remove and 0 not upgraded.

Need to get 64.7 kB/17.7 MB of archives. After unpacking 63.1 MB will be used.

Writing extended state information...

Get: 1 http://ftp.fr.debian.org/debian/ jessie/main python-unittest2 all 0.5.1-1 [64.7 kB]

Fetched 64.7 kB in 0s (3224 kB/s)

Extracting templates from packages: 83%
Extracting templates from packages: 100%

Preconfiguring packages ...

E: Can not write log (Is /dev/pts mounted?) - posix_openpt (2: No such file or directory)

Selecting previously unselected package libpipeline1:amd64.

(Reading database ... 12579 files and directories currently installed.)

Preparing to unpack .../libpipeline1_1.4.0-1_amd64.deb ...

Unpacking libpipeline1:amd64 (1.4.0-1) ...

Selecting previously unselected package groff-base.

Preparing to unpack .../groff-base_1.22.2-8_amd64.deb ...

Unpacking groff-base (1.22.2-8) ...

Selecting previously unselected package bsdmainutils.

Preparing to unpack .../bsdmainutils_9.0.6_amd64.deb ...

Unpacking bsdmainutils (9.0.6) ...

Selecting previously unselected package man-db.

Preparing to unpack .../man-db_2.7.0.2-5_amd64.deb ...

Unpacking man-db (2.7.0.2-5) ...

Selecting previously unselected package libasprintf0c2:amd64.

Preparing to unpack .../libasprintf0c2_0.19.3-2_amd64.deb ...

Unpacking libasprintf0c2:amd64 (0.19.3-2) ...

Selecting previously unselected package libmagic1:amd64.

Preparing to unpack .../libmagic1_1%3a5.22+15-2+deb8u1_amd64.deb ...

Unpacking libmagic1:amd64 (1:5.22+15-2+deb8u1) ...

Selecting previously unselected package libxml2:amd64.

Preparing to unpack .../libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb ...

Unpacking libxml2:amd64 (2.9.1+dfsg1-5+deb8u1) ...

Selecting previously unselected package libpython2.7-minimal:amd64.

Preparing to unpack .../libpython2.7-minimal_2.7.9-2_amd64.deb ...

Unpacking libpython2.7-minimal:amd64 (2.7.9-2) ...

Selecting previously unselected package python2.7-minimal.

Preparing to unpack .../python2.7-minimal_2.7.9-2_amd64.deb ...

Unpacking python2.7-minimal (2.7.9-2) ...

Selecting previously unselected package python-minimal.

Preparing to unpack .../python-minimal_2.7.9-1_amd64.deb ...

Unpacking python-minimal (2.7.9-1) ...

Selecting previously unselected package mime-support.

Preparing to unpack .../mime-support_3.58_all.deb ...

Unpacking mime-support (3.58) ...

Selecting previously unselected package libexpat1:amd64.

Preparing to unpack .../libexpat1_2.1.0-6+deb8u1_amd64.deb ...

Unpacking libexpat1:amd64 (2.1.0-6+deb8u1) ...

Selecting previously unselected package libpython2.7-stdlib:amd64.

Preparing to unpack .../libpython2.7-stdlib_2.7.9-2_amd64.deb ...

Unpacking libpython2.7-stdlib:amd64 (2.7.9-2) ...

Selecting previously unselected package python2.7.

Preparing to unpack .../python2.7_2.7.9-2_amd64.deb ...

Unpacking python2.7 (2.7.9-2) ...

Selecting previously unselected package libpython-stdlib:amd64.

Preparing to unpack .../libpython-stdlib_2.7.9-1_amd64.deb ...

Unpacking libpython-stdlib:amd64 (2.7.9-1) ...

Setting up libpython2.7-minimal:amd64 (2.7.9-2) ...

Setting up python2.7-minimal (2.7.9-2) ...

Setting up python-minimal (2.7.9-1) ...

Selecting previously unselected package python.

(Reading database ... 13944 files and directories currently installed.)

Preparing to unpack .../python_2.7.9-1_amd64.deb ...

Unpacking python (2.7.9-1) ...

Selecting previously unselected package libglib2.0-0:amd64.

Preparing to unpack .../libglib2.0-0_2.42.1-1+b1_amd64.deb ...

Unpacking libglib2.0-0:amd64 (2.42.1-1+b1) ...

Selecting previously unselected package libcroco3:amd64.

Preparing to unpack .../libcroco3_0.6.8-3+b1_amd64.deb ...

Unpacking libcroco3:amd64 (0.6.8-3+b1) ...

Selecting previously unselected package libmpdec2:amd64.

Preparing to unpack .../libmpdec2_2.4.1-1_amd64.deb ...

Unpacking libmpdec2:amd64 (2.4.1-1) ...

Selecting previously unselected package libpython3.4-minimal:amd64.

Preparing to unpack .../libpython3.4-minimal_3.4.2-1_amd64.deb ...

Unpacking libpython3.4-minimal:amd64 (3.4.2-1) ...

Selecting previously unselected package libpython3.4-stdlib:amd64.

Preparing to unpack .../libpython3.4-stdlib_3.4.2-1_amd64.deb ...

Unpacking libpython3.4-stdlib:amd64 (3.4.2-1) ...

Selecting previously unselected package libunistring0:amd64.

Preparing to unpack .../libunistring0_0.9.3-5.2+b1_amd64.deb ...

Unpacking libunistring0:amd64 (0.9.3-5.2+b1) ...

Selecting previously unselected package python3.4-minimal.

Preparing to unpack .../python3.4-minimal_3.4.2-1_amd64.deb ...

Unpacking python3.4-minimal (3.4.2-1) ...

Selecting previously unselected package file.

Preparing to unpack .../file_1%3a5.22+15-2+deb8u1_amd64.deb ...

Unpacking file (1:5.22+15-2+deb8u1) ...

Selecting previously unselected package gettext-base.

Preparing to unpack .../gettext-base_0.19.3-2_amd64.deb ...

Unpacking gettext-base (0.19.3-2) ...

Selecting previously unselected package python-support.

Preparing to unpack .../python-support_1.0.15_all.deb ...

Unpacking python-support (1.0.15) ...

Selecting previously unselected package gettext.

Preparing to unpack .../gettext_0.19.3-2_amd64.deb ...

Unpacking gettext (0.19.3-2) ...

Selecting previously unselected package intltool-debian.

Preparing to unpack .../intltool-debian_0.35.0+20060710.1_all.deb ...

Unpacking intltool-debian (0.35.0+20060710.1) ...

Selecting previously unselected package po-debconf.

Preparing to unpack .../po-debconf_1.0.16+nmu3_all.deb ...

Unpacking po-debconf (1.0.16+nmu3) ...

Selecting previously unselected package debhelper.

Preparing to unpack .../debhelper_9.20150101_all.deb ...

Unpacking debhelper (9.20150101) ...

Selecting previously unselected package python3.4.

Preparing to unpack .../python3.4_3.4.2-1_amd64.deb ...

Unpacking python3.4 (3.4.2-1) ...

Selecting previously unselected package python3-minimal.

Preparing to unpack .../python3-minimal_3.4.2-2_amd64.deb ...

Unpacking python3-minimal (3.4.2-2) ...

Selecting previously unselected package libpython3-stdlib:amd64.

Preparing to unpack .../libpython3-stdlib_3.4.2-2_amd64.deb ...

Unpacking libpython3-stdlib:amd64 (3.4.2-2) ...

Selecting previously unselected package python3.

Preparing to unpack .../python3_3.4.2-2_amd64.deb ...

Unpacking python3 (3.4.2-2) ...

Selecting previously unselected package dh-python.

Preparing to unpack .../dh-python_1.20141111-2_all.deb ...

Unpacking dh-python (1.20141111-2) ...

Selecting previously unselected package python-unittest2.

Preparing to unpack .../python-unittest2_0.5.1-1_all.deb ...

Unpacking python-unittest2 (0.5.1-1) ...

Setting up libpipeline1:amd64 (1.4.0-1) ...

Setting up groff-base (1.22.2-8) ...

Setting up bsdmainutils (9.0.6) ...

update-alternatives: using /usr/bin/bsd-write to provide /usr/bin/write (write) in auto mode

update-alternatives: using /usr/bin/bsd-from to provide /usr/bin/from (from) in auto mode

Setting up man-db (2.7.0.2-5) ...

Not building database; man-db/auto-update is not &#39;true&#39;.

Setting up libasprintf0c2:amd64 (0.19.3-2) ...

Setting up libmagic1:amd64 (1:5.22+15-2+deb8u1) ...

Setting up libxml2:amd64 (2.9.1+dfsg1-5+deb8u1) ...

Setting up mime-support (3.58) ...

Setting up libexpat1:amd64 (2.1.0-6+deb8u1) ...

Setting up libpython2.7-stdlib:amd64 (2.7.9-2) ...

Setting up python2.7 (2.7.9-2) ...

Setting up libpython-stdlib:amd64 (2.7.9-1) ...

Setting up python (2.7.9-1) ...

Setting up libglib2.0-0:amd64 (2.42.1-1+b1) ...

No schema files found: doing nothing.

Setting up libcroco3:amd64 (0.6.8-3+b1) ...

Setting up libmpdec2:amd64 (2.4.1-1) ...

Setting up libpython3.4-minimal:amd64 (3.4.2-1) ...

Setting up libpython3.4-stdlib:amd64 (3.4.2-1) ...

Setting up libunistring0:amd64 (0.9.3-5.2+b1) ...

Setting up python3.4-minimal (3.4.2-1) ...

Setting up file (1:5.22+15-2+deb8u1) ...

Setting up gettext-base (0.19.3-2) ...

Setting up python-support (1.0.15) ...

Setting up gettext (0.19.3-2) ...

Setting up intltool-debian (0.35.0+20060710.1) ...

Setting up po-debconf (1.0.16+nmu3) ...

Setting up debhelper (9.20150101) ...

Setting up python3.4 (3.4.2-1) ...

Setting up python3-minimal (3.4.2-2) ...

Setting up libpython3-stdlib:amd64 (3.4.2-2) ...

Setting up python-unittest2 (0.5.1-1) ...

Setting up dh-python (1.20141111-2) ...

Setting up python3 (3.4.2-2) ...

Processing triggers for libc-bin (2.19-18+deb8u4) ...

Processing triggers for python-support (1.0.15) ...

Reading package lists...

Building dependency tree...

Reading state information...

Reading extended state information...

Initializing package states...

Writing extended state information...

Building tag database...

-&gt; Finished parsing the build-deps

Reading package lists...

Building dependency tree...

Reading state information...

apt-utils is already the newest version.

The following NEW packages will be installed:

fakeroot libfakeroot

0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.

Need to get 0 B/129 kB of archives.

After this operation, 434 kB of additional disk space will be used.

E: Can not write log (Is /dev/pts mounted?) - posix_openpt (2: No such file or directory)

Selecting previously unselected package libfakeroot:amd64.

(Reading database ... 15836 files and directories currently installed.)

Preparing to unpack .../libfakeroot_1.20.2-1_amd64.deb ...

Unpacking libfakeroot:amd64 (1.20.2-1) ...

Selecting previously unselected package fakeroot.

Preparing to unpack .../fakeroot_1.20.2-1_amd64.deb ...

Unpacking fakeroot (1.20.2-1) ...

Processing triggers for man-db (2.7.0.2-5) ...

Not building database; man-db/auto-update is not &#39;true&#39;.

Setting up libfakeroot:amd64 (1.20.2-1) ...

Setting up fakeroot (1.20.2-1) ...

update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode

I: Copying back the cached apt archive contents

I: new cache content python-unittest2_0.5.1-1_all.deb added

I: Copying source file

I: copying [/tmp/tmpkWXpdZ/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.dsc]

I: copying [/tmp/tmpkWXpdZ/cubicweb-mediaplayer_0.2.1.orig.tar.gz]

I: copying [/tmp/tmpkWXpdZ/cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.diff.gz]

I: Extracting source

dpkg-source: warning: extracting unsigned source package (cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.dsc)

dpkg-source: info: extracting cubicweb-mediaplayer in cubicweb-mediaplayer-0.2.1

dpkg-source: info: unpacking cubicweb-mediaplayer_0.2.1.orig.tar.gz

dpkg-source: info: applying cubicweb-mediaplayer_0.2.1-1~revf64645f01b93.diff.gz

I: Building the package

W: no hooks of type A found -- ignoring

I: Running cd tmp/buildd/*/ &amp;&amp; env PATH=&quot;/usr/sbin:/usr/bin:/sbin:/bin&quot; dpkg-buildpackage -us -uc -rfakeroot

dpkg-buildpackage: source package cubicweb-mediaplayer

dpkg-buildpackage: source version 0.2.1-1~revf64645f01b93

dpkg-buildpackage: source distribution jessie

dpkg-buildpackage: source changed by David Douard &lt;david.douard@logilab.fr&gt;

dpkg-source --before-build cubicweb-mediaplayer-0.2.1

dpkg-buildpackage: host architecture amd64

fakeroot debian/rules clean

debian/rules:7: *** missing separator. Stop.

dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

E: Failed autobuilding of package

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/C10shell starting

If you want to enter into the chroot image to debug, you have to edit your ~/.pbuilderrc with:

export LGP_AUTO_ENTER_SHELL=y

I: user script /var/cache/pbuilder/build//25603/tmp/hooks/C10shell finished

I: unmounting /sys filesystem

I: unmounting /dev filesystem

I: unmounting dev/pts filesystem

I: unmounting run/shm filesystem

I: unmounting proc filesystem

I: cleaning the build env

I: removing directory /var/cache/pbuilder/build//25603 and its subdirectories
<br/>

log from execution