consoleText

download

20 Started by upstream project "cubes-oaipmh" build number 8
originally caused by:
Started by an SCM change
Building on master in workspace /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27
[py27] $ hg showconfig paths.default
[py27] $ hg pull --rev 4963ec8e5efe97ff4d7cf8733858666b789ed0e5
pulling from http://hg.logilab.org/review/cubes/oaipmh
searching for changes
adding changesets
adding manifests
adding file changes
added 2 changesets with 7 changes to 7 files
(run 'hg update' to get a working copy)
[py27] $ hg update --clean --rev 4963ec8e5efe97ff4d7cf8733858666b789ed0e5
7 files updated, 0 files merged, 0 files removed, 0 files unresolved
[py27] $ hg --config extensions.purge= clean --all
[py27] $ hg log --rev . --template {node}
[py27] $ hg log --rev . --template {rev}
[py27] $ hg log --rev f1121c9cf9b088f64926206e6021dafbb864d9df
changeset: 7:f1121c9cf9b0
tag: 0.1.0
tag: centos/0.1.0
tag: debian/0.1.0
user: Sylvain ThĂŠnault <sylvain.thenault@logilab.fr>
date: Tue May 10 18:14:06 2016 +0200
summary: prepare publication of a 0.1

[py27] $ hg log --template "<changeset node='{node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n" --rev 4963ec8e5efe97ff4d7cf8733858666b789ed0e5:0 --follow --prune f1121c9cf9b088f64926206e6021dafbb864d9df --encoding UTF-8 --encodingmode replace
[py27] $ /bin/bash -xe /tmp/hudson6134502283862096342.sh
+ find . -name 'tmpdb*' -delete
[py27] $ /bin/bash -xe /tmp/hudson3046442121290467722.sh
+ tox --recreate
GLOB sdist-make: /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/setup.py
py27 create: /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/.tox/py27
py27 installdeps: pytest
py27 inst: /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/.tox/dist/cubicweb-oaipmh-0.1.0.zip
py27 installed: You are using pip version 7.1.2, however version 8.1.2 is available.,You should consider upgrading via the 'pip install --upgrade pip' command.,beautifulsoup4==4.3.2,boto==2.34.0,bzr-etckeeper==0.0.0,cffi==0.8.6,characteristic==0.1.0,chardet==2.3.0,Cheetah==2.4.4,cloud-init==0.7.6,colorama==0.3.2,configobj==5.0.6,coverage==3.7.1,croniter==0.3.4,cryptography==0.6.1,cubicweb==3.23.1,cubicweb-oaipmh==0.1.0,cwclientlib==0.4.1,Cython==0.21.1,decorator==3.4.0,docutils==0.12,ecdsa==0.11,euca2ools==3.1.0,GDAL==1.10.1,hg-evolve==5.4.0,html2text==2016.5.29,html5lib==0.999,isodate==0.5.0,Jinja2==2.7.3,joblib==0.8.3,jsonpatch==1.3,jsonpointer==1.0,linecache2==1.0.0,logilab-common==1.2.2,logilab-constraint==0.6.0,logilab-database==1.15.0,logilab-mtconverter==0.9.0,lxml==3.4.0,M2Crypto==0.21.1,Mako==1.0.0,Markdown==2.5.1,MarkupSafe==0.23,matplotlib==1.4.2,mccabe==0.2.1,mercurial==3.7.3,mock==1.0.1,msgpack-python==0.4.2,nose==1.3.4,numexpr==2.4,numpy==1.8.2,oauth==1.0.1,openpyxl==1.7.0,pandas==0.14.1,paramiko==1.15.1,passlib==1.6.5,pep8==1.5.7,Pillow==2.6.1,pluggy==0.3.1,ply==3.4,prettytable==0.7.2,psycopg2==2.5.4,py==1.4.31,pyasn1==0.1.7,pyasn1-modules==0.0.5,pycparser==2.10,pycrypto==2.6.1,pyflakes==0.8.1,Pygments==2.0.1,pyinotify==0.9.4,pyOpenSSL==0.14,pyparsing==2.0.3,pyserial==2.6,pysqlite==2.6.3,pytest==2.9.2,python-apt==0.9.3.12,python-augeas==0.4.1,python-dateutil==2.2,python-jenkins==0.2.1,python-ldap==2.4.10,python-yapps==2.1.1,python3-ldap==0.9.4.2,pytz==2012rc0,PyYAML==3.11,pyzmq==14.4.0,rdflib==4.1.2,requestbuilder==0.2.3,requests==2.4.3,roman==2.0.0,rql==0.34.0,rubber==1.1,salt==2015.5.3,scikit-learn==0.14.1,scipy==0.14.0,service-identity==1.0.0,Shapely==1.4.3,simplejson==3.6.5,SimpleTAL==4.1,six==1.8.0,SPARQLWrapper==1.6.0,Sphinx==1.2.3,statsmodels==0.4.2,tables==3.1.1,tox==2.3.1,traceback2==1.4.0,unittest2==1.1.0,urllib3==1.9.1,virtualenv==13.1.2,wheel==0.24.0,xlrd==0.9.2,xlwt==0.7.5,yams==0.44.0,Yapps==2.2.0,Yapps2==2.2.0
py27 runtests: PYTHONHASHSEED='159811906'
py27 runtests: commands[0] | /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/.tox/py27/bin/python -m pytest /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/test
============================= test session starts ==============================
platform linux2 -- Python 2.7.9, pytest-2.9.2, py-1.4.31, pluggy-0.3.1
rootdir: /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27, inifile:
collected 0 items / 1 errors

==================================== ERRORS ====================================
_____________________ ERROR collecting test/test_oaipmh.py _____________________
test/test_oaipmh.py:33: in <module>
from cubes.oaipmh.entities import OAIComponent
.tox/py27/share/cubicweb/cubes/oaipmh/entities.py:27: in <module>
from cubes.oaipmh import isodate
E ImportError: cannot import name isodate
=========================== 1 error in 0.38 seconds ============================
ERROR: InvocationError: '/var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/.tox/py27/bin/python -m pytest /var/lib/jenkins/jobs/cubes-oaipmh/workspace/TOXENV/py27/test'
___________________________________ summary ____________________________________
ERROR: py27: commands failed
Build step 'Execute shell' marked build as failure
Sending e-mails to: denis.laxalde@logilab.fr
[PostBuildScript] - Execution post build scripts.
[py27] $ /bin/bash -xe /tmp/hudson8331099057706032252.sh
+ /var/lib/jenkins/scripts/notify_forge_apycot.py cwo cubicweb-oaipmh 4963ec8e5efe http://jenkins.logilab.fr/job/cubes-oaipmh/TOXENV=py27/8/ --status failure
<br/>

log from execution
download