consoleText

download

20 Started by upstream project "cubes-datacat" build number 21
originally caused by:
Started by an SCM change
Building on master in workspace /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27
[py27] $ hg showconfig paths.default
[py27] $ hg pull --rev d426a6f71908be18d2c28d6daca14d2ecfcb55db
pulling from http://hg.logilab.org/review/cubes/datacat
searching for changes
adding changesets
adding manifests
adding file changes
added 1 changesets with 1 changes to 1 files
(run 'hg update' to get a working copy)
[py27] $ hg update --clean --rev d426a6f71908be18d2c28d6daca14d2ecfcb55db
1 files updated, 0 files merged, 0 files removed, 0 files unresolved
[py27] $ hg --config extensions.purge= clean --all
[py27] $ hg log --rev . --template {node}
[py27] $ hg log --rev . --template {rev}
[py27] $ hg log --rev b901a4fe68da6c5bde03a5c90f7956e8763b0f73
changeset: 510:b901a4fe68da
parent: 508:9a9943a63181
user: Denis Laxalde <denis.laxalde@logilab.fr>
date: Thu Aug 18 10:29:39 2016 +0200
summary: [views] Remove 'dcat.rdf.ckan' views and map it to 'dcat.rdf.complete' for bwcompat

[py27] $ hg log --template "<changeset node='{node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n" --rev d426a6f71908be18d2c28d6daca14d2ecfcb55db:0 --follow --prune b901a4fe68da6c5bde03a5c90f7956e8763b0f73 --encoding UTF-8 --encodingmode replace
[py27] $ /bin/bash -xe /tmp/hudson7429749734499214257.sh
+ find test/data -name 'tmpdb*' -delete
[py27] $ /bin/bash -xe /tmp/hudson2982091776433849100.sh
+ tox --recreate
GLOB sdist-make: /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/setup.py
py27 create: /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27
py27 installdeps: mock, pytest, https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing
ERROR: invocation failed (exit code 1), logfile: /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/log/py27-1.log
ERROR: actionid: py27
msg: getenv
cmdargs: [local('/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/bin/pip'), 'install', 'mock', 'pytest', 'https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing']
env: {'JENKINS_HOME': '/var/lib/jenkins', 'HUDSON_URL': 'http://jenkins.logilab.fr/', 'BUILD_URL': 'http://jenkins.logilab.fr/job/cubes-datacat/TOXENV=py27/21/', 'BUILD_TAG': 'jenkins-cubes-datacat-TOXENV=py27-21', 'HUDSON_SERVER_COOKIE': 'a2527b0ba4577e4a', 'JENKINS_URL': 'http://jenkins.logilab.fr/', 'LOGNAME': 'jenkins', 'USER': 'jenkins', 'WORKSPACE': '/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27', 'HOME': '/var/lib/jenkins', 'PATH': '/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games', 'JOB_NAME': 'cubes-datacat/TOXENV=py27', 'LANG': 'en_US.UTF-8', 'VIRTUAL_ENV': '/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27', 'SHELL': '/bin/bash', 'SHLVL': '2', 'HUDSON_HOME': '/var/lib/jenkins', 'NODE_LABELS': 'master', 'PYTHONHASHSEED': '1122882205', 'BUILD_ID': '21', 'TOXENV': 'py27', 'HUDSON_COOKIE': '53b9acd3-5359-46d5-9e9a-da2b64d92813', 'JOB_URL': 'http://jenkins.logilab.fr/job/cubes-datacat/TOXENV=py27/', 'JOB_BASE_NAME': 'TOXENV=py27', '_': '/usr/local/bin/tox', 'BUILD_NUMBER': '21', 'MERCURIAL_REVISION_NUMBER': '511', 'MERCURIAL_REVISION': 'd426a6f71908be18d2c28d6daca14d2ecfcb55db', 'EXECUTOR_NUMBER': '1', 'NODE_NAME': 'master', 'PWD': '/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27', 'JENKINS_SERVER_COOKIE': 'a2527b0ba4577e4a', 'BUILD_DISPLAY_NAME': '#21', 'MERCURIAL_REVISION_SHORT': 'd426a6f71908', 'MAIL': '/var/mail/jenkins', 'MERCURIAL_REPOSITORY_URL': 'http://hg.logilab.org/review/cubes/datacat'}

Requirement already satisfied (use --upgrade to upgrade): mock in /usr/lib/python2.7/dist-packages
Collecting pytest
Using cached pytest-3.0.1-py2.py3-none-any.whl
Collecting cubicweb-dataprocessing from https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing
Downloading https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2
Requirement already satisfied (use --upgrade to upgrade): py>=1.4.29 in /usr/local/lib/python2.7/dist-packages (from pytest)
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.0 in /usr/lib/python2.7/dist-packages (from cubicweb-dataprocessing)
Collecting cubicweb>=3.24.0.dev0 (from cubicweb-dataprocessing)
Could not find a version that satisfies the requirement cubicweb>=3.24.0.dev0 (from cubicweb-dataprocessing) (from versions: 3.0.4, 3.3.0, 3.3.1, 3.3.4, 3.4.2, 3.4.4, 3.4.6, 3.5.1, 3.5.11, 3.5.12, 3.6.0, 3.6.1, 3.7.0, 3.7.2, 3.7.3, 3.7.4, 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5, 3.8.6, 3.9.0, 3.9.1, 3.9.2, 3.9.3, 3.9.4, 3.9.5, 3.9.6, 3.9.8, 3.10.0, 3.10.1, 3.10.2, 3.10.7, 3.10.8, 3.11.0, 3.11.1, 3.12.1, 3.12.3, 3.12.4, 3.12.5, 3.12.6, 3.12.7, 3.12.8, 3.12.9, 3.13.0, 3.13.1, 3.13.2, 3.13.3, 3.13.4, 3.13.5, 3.13.6, 3.13.7, 3.13.8, 3.13.9, 3.13.10, 3.14.0, 3.14.1, 3.14.2, 3.14.10, 3.15.2, 3.15.6, 3.15.7, 3.15.8, 3.15.9, 3.15.11, 3.16.0, 3.16.1, 3.16.2, 3.16.5, 3.16.6, 3.17.0, 3.17.1, 3.17.2, 3.17.3, 3.17.4, 3.17.5, 3.17.7, 3.17.8, 3.17.9, 3.17.10, 3.17.11, 3.17.12, 3.17.13, 3.17.14, 3.17.15, 3.17.16, 3.17.17, 3.17.18, 3.18.0, 3.18.1, 3.18.2, 3.18.3, 3.18.4, 3.18.5, 3.18.6, 3.18.7, 3.18.8, 3.19.0, 3.19.1, 3.19.2, 3.19.3, 3.19.4, 3.19.5, 3.19.6, 3.19.7, 3.19.8, 3.19.9, 3.19.10, 3.19.11, 3.19.12, 3.19.13, 3.19.14, 3.20.0, 3.20.1, 3.20.2, 3.20.3, 3.20.4, 3.20.5, 3.20.6, 3.20.7, 3.20.8, 3.20.9, 3.20.10, 3.20.11, 3.20.12, 3.20.13, 3.20.14, 3.20.15, 3.20.16, 3.21.0, 3.21.1, 3.21.2, 3.21.3, 3.21.4, 3.21.5, 3.21.6, 3.22.0, 3.22.1, 3.22.2, 3.22.3, 3.22.4, 3.23.0, 3.23.1)
No matching distribution found for cubicweb>=3.24.0.dev0 (from cubicweb-dataprocessing)
You are using pip version 7.1.2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

ERROR: could not install deps [mock, pytest, https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing]; v = InvocationError('/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/bin/pip install mock pytest https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing (see /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/log/py27-1.log)', 1)
___________________________________ summary ____________________________________
ERROR: py27: could not install deps [mock, pytest, https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing]; v = InvocationError('/var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/bin/pip install mock pytest https://hg.logilab.org/review/cubes/dataprocessing/archive/602206ebe1bf.tar.bz2#egg=cubicweb-dataprocessing (see /var/lib/jenkins/jobs/cubes-datacat/workspace/TOXENV/py27/.tox/py27/log/py27-1.log)', 1)
Build step 'Execute shell' marked build as failure
Sending e-mails to: dlaxalde@logilab.fr yvote@logilab.fr
[PostBuildScript] - Execution post build scripts.
[py27] $ /bin/bash -xe /tmp/hudson1332796563409876290.sh
+ /var/lib/jenkins/scripts/notify_forge_apycot.py cwo cubicweb-datacat d426a6f71908 http://jenkins.logilab.fr/job/cubes-datacat/TOXENV=py27/21/ --status failure
<br/>

log from execution
download