[pkg] prepare 4.0.0

authorDavid Douard <david.douard@logilab.fr>
changesete3aad84adf03
branchdefault
phasedraft
hiddenno
parent revision#69394bafe4bd [narval] the lgp_suffix option of lgp.build checker is now used as is
child revision<not specified>
files modified by this revision
__pkginfo__.py
debian/control
# HG changeset patch
# User David Douard <david.douard@logilab.fr>
# Date 1421155140 -3600
# Tue Jan 13 14:19:00 2015 +0100
# Node ID e3aad84adf034f262d657af1ece4d5caebd2d487
# Parent 69394bafe4bd4a553e1b166b0dd9f054524fb242
[pkg] prepare 4.0.0

diff --git a/__pkginfo__.py b/__pkginfo__.py
@@ -2,11 +2,11 @@
1  """cubicweb-apycot application packaging information"""
2 
3  modname = 'apycotlib'
4  distname = 'apycot'
5 
6 -numversion = (3, 2, 0)
7 +numversion = (4, 0, 0)
8  version = '.'.join(str(num) for num in numversion)
9 
10  license = 'GPL'
11  description = 'Continuous testing / integration tool for the CubicWeb framework'
12  author = 'Logilab'
@@ -20,19 +20,22 @@
13      ]
14 
15  __depends__ = {'cubicweb': '>= 3.19.0',
16                 'cubicweb-vcsfile': '>= 2',
17                 'cubicweb-file': None,
18 -               'cubicweb-narval': '>= 4.1',
19 +               'cubicweb-narval': '>= 4.2',
20 +               'python-hglib': '>= 1.4',
21                 'Pygments': None,
22                 'lxml': None,
23                 'logilab-packaging': '>= 1.0.0',
24                 }
25  __recommends__ = {'cubicweb-tracker': None,
26                    'cubicweb-nosylist': '>= 0.5.0',
27                    'cubicweb-jqplot': '>= 0.1.2',
28                    'coverage': None,
29 +                  'pylint': None,
30 +                  'coverage': None,
31                    }
32 
33  # packaging ###
34 
35  from os import listdir as _listdir
diff --git a/debian/control b/debian/control
@@ -13,11 +13,11 @@
36  Architecture: all
37  Depends:
38   cubicweb-common (>= 3.19),
39   cubicweb-vcsfile (>= 2),
40   cubicweb-file (>= 1.14),
41 - cubicweb-narval (>= 4.1),
42 + cubicweb-narval (>= 4.2),
43   python-pygments,
44   ${misc:Depends},
45   ${python:Depends},
46  Recommends: cubicweb-jqplot (>= 0.1.2)
47  Suggests:
@@ -30,14 +30,13 @@
48   CubicWeb is a semantic web application framework, see http://www.cubicweb.org
49 
50  Package: narval-apycot
51  Architecture: all
52  Depends:
53 - narval-bot (>= 4.1),
54 + narval-bot (>= 4.2),
55   python-unittest2 | python (>= 2.7),
56   python-lxml,
57 - mercurial (>= 2.2),
58   python-logilab-packaging,
59   ${misc:Depends},
60   ${python:Depends},
61  Recommends:
62   pylint,