cubicweb-dataio #10269669 adapt to cw > 3.20 api [validation pending]

Adapt the cube to cw > 3.20 api * do not use dbapi in ccplugin

prioritynormal
typeenhancement
done in0.7.0
load left0.000
closed by#15d2e54c076b [ccplugin] stop using dbapi (closes #10269669)
patch[ccplugin] stop using dbapi (closes #10269669) [applied]