cubicweb #10927494 pb with constraints in database and older version of sqlite [validation pending]

Redhat 6 has an old version of sqlite which doesn't put the constraint name in integrity error messages. This breaks the expectation of cw > 3.21 which makes the database handle those constraints and attempt to link integrity error and yams schema constraint using those names.

prioritynormal
typebug
done in3.22.2
load left0.000
closed by#517e7cdd7b1b [schema] restore constraint checking when running on old sqlite
patchold sqlite3 doesn't provide CHECK constraint names in error messages [applied]