cubicweb #1196 use better names for default selectors [resolved]

Selectors names such as nfentity_selector or etype_rtype_selector should be changed and made more explicit and he _selector suffix is debatable and redundant.

Besides, it might be nice to get rid of the chainall and chainfirst functions and use the | and & operators, e.g.:

__selectors__ = (sel1 | sel2) & sel3

instead of:

__select__ = classmethod(chainall(chainfirst(sel1, sel2), sel3))
done in3.2.0
load left0.000
closed by<not specified>