cubicweb-celery #15599451 broken with cubicweb 3.24 [validation pending]

cubicweb 3.24 introduces an import redirect hook which attempts to find a cubicweb_<cubename> module when encountering import cubes.<cubename>. The strange packaging in this cube having a cubiweb_celery package installed in site-packages makes this mechanism fail to import submodules of cubes.celery.

not sure we should "fix" cubicweb for this singularity, rather fixing things here by just moving this cube into a standard package layout and getting rid of all strange things along the way.

done in0.3.0
load left0.000
closed by#117ba0fe2252 Move to package layout
patchMove to package layout [applied]