cubicweb #16404515 pkg_resources.VersionConflict: (unittest2 0.5.1 (/usr/lib/pymodules/python2.7), Requirement.parse('unittest2>=0.7.0')) [validation pending]

when installing python-cubicweb 3.24.3 with --install-no-recommends I get

::

# cubicweb-ctl Traceback (most recent call last): File "/usr/bin/cubicweb-ctl", line 4, in <module>

ReST / HTML errors:System Message: ERROR/3 (&lt;string&gt; , line 7)</p>
Unexpected indentation.
run(sys.argv[1:])
ReST / HTML errors:System Message: WARNING/2 (&lt;string&gt; , line 8)</p>
Block quote ends without a blank line; unexpected unindent.
File "/usr/lib/python2.7/dist-packages/cubicweb/cwctl.py", line 1070, in run
cwcfg.load_cwctl_plugins()
File "/usr/lib/python2.7/dist-packages/cubicweb/cwconfig.py", line 698, in load_cwctl_plugins
for cube in cls.available_cubes():
File "/usr/lib/python2.7/dist-packages/cubicweb/cwconfig.py", line 473, in available_cubes
module = entry_point.load()
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2188, in load
self.require(env, installer)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2202, in require
items = working_set.resolve(reqs, env, installer)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 644, in resolve
raise VersionConflict(dist, req)
ReST / HTML errors:System Message: WARNING/2 (&lt;string&gt; , line 20)</p>
Definition list ends without a blank line; unexpected unindent.

pkg_resources.VersionConflict: (unittest2 0.5.1 (/usr/lib/pymodules/python2.7), Requirement.parse('unittest2>=0.7.0'))

the setup.py says install_requires=unittest2>=0.7.0 but debian control file has it in recommends.

prioritynormal
typebug
done in3.24.4
load0.100
load left0.000
closed by#861d87a439f2 [debian] move unittest2 to requires not recommends closes #16404515
patch[debian/control] logilab >= 1.2.2 in requires (only in build depends) #16404515 [applied]move unittest2 to requires not recommends closes #16404515 [applied]