cubicweb #17065626 restrict yams version to be < 0.45 [validation pending]

Yams 0.45 has some breaking changes that went unnoticed before release. Some are simple API changes that can be fixed (like https://hg.logilab.org/master/yams/rev/6b2d37bad9e3) but others are more subtle and not obvious to fix (see this build log for instance).

So better be strict in yams version again.

priorityimportant
typetask
done in3.24.7
load left0.000
closed by#10d3bf220be2 [pkg] Restrict yams version to be less than 0.45.0
patch[pkg] Restrict yams version to be less than 0.45.0 [applied]