cubicweb #2296057 clone_deps.py is broken with recent versions of mercurial [validation pending]

clone_deps.py uses the direct mercurial API dispatch which has changed in recent version. It would seem best to force using the command line API.

prioritynormal
typebug
done in3.14.8
load0.100
load left0.000
closed by#c6c76bf518d1 [bin] Force clone_deps.py to use mercurial command-line interface - closes #2296057