cubicweb-varnish #2430008 support varnish 3 purge commands [validation pending]

Currently, the ``purge.url`` is currently used but is only supported by varnish 2.x. Version 3.x only understands ``ban.url``. We should have an option to indicate which version of varnish is used.
prioritynormal
typeenhancement
done in0.2.0
load0.100
load left0.000
closed by<not specified>