cubicweb #2541602 python 2.5: missing "import with_statement" [done]

Missing from future import with_statement in server/sources/ldap_user.py to keep compatibility with Python 2.5

prioritynormal
typebug
done in3.15.8
load0.100
load left0.000
closed by#c491f945f878 [ldapsource] keep python 2.5 compatibility (closes #2541602)