cubicweb #2786674 Upgrade bundled jquery to 1.10 [validation pending]

The latest version of bootstrap requires a newer version of jquery (at least 1.8), while cubicweb is currently shipping version 1.6.4.

There are a couple of upgrade options:

  • 1.8.3: same API as 1.6/1.7 (with a couple new features of course)
  • 1.9.1/1.10: new API, cleaned up from deprecated APIs. Has a companion plugin implementing deprecated APIs.
  • 2.0.x: new API (the same as 1.9) but no companion plugin is available. Drops support for old(er) browsers, IE6/7 notably.

Please discuss.

prioritynormal
typeenhancement
done in3.18.0
load2.000
load left0.000
closed by#4c34a63bd113 update jquery to 1.10 (closes #2786674)
patch[web/data] WIP upgrade to jQuery 1.8.3 (closes #2786674) WIP [folded]update jquery to 1.10 (closes #2786674) [applied][js] noop is undefined in plain javascript (related to #2786674) [applied]