cubicweb #2786886 Retreiver -> Retriever [done]

It looks like there's a typo in the name of two classes in web/views/authentication.py:
LoginPasswordRetreiver -> LoginPasswordRetriever
WebAuthInfoRetreiver -> WebAuthInfoRetriever
I don't know whether it's possible to fix by renaming the classes without breaking too much code.

priorityminor
typebug
done in<not specified>
load left0.000
closed by<not specified>