cubicweb-array #3036180 rename FVALUE and VALUE to ARRAY_GET [validation pending]

Since array functions in pg are prefixed by array_, it would be more consistent to follow the same naming convention.

Furthermore, there's no need for SQL stored procedures as the translation from RQL to SQL is trivial.

prioritynormal
typeenhancement
done in0.1.0
load0.100
load left0.000
closed by#020cc63688f6 Rename VALUE to ARRAY_GET, declare rql to sql mapping directly in FunctionDescr (closes #3036180)
patchadd FVALUE stored procedure: analog to VALUE but on float [applied]Rename VALUE to ARRAY_GET, declare rql to sql mapping directly in FunctionDescr [folded]