cubicweb #342872 check status of other postgres dbapi modules [deprecated]

currently we're always using psycopg2. Some reported bugs have shown that pgdb support is broken. We should also check the status pgsql.

Then, either make those other modules work or set a hard-dependency on psycopg (or at least document that).

prioritynormal
typeenhancement
done in<not specified>
load0.000
load left0.000
closed by<not specified>