cubicweb #343616 use py2.5 sqlite3 module [done]

so cw developpers can work without pysqlite2. Ideally we should be able to work with both module (see lgc.db)

prioritynormal
typeenhancement
done in<not specified>
load1.000
load left0.000
closed by<not specified>