cubicweb #4071285 dbapi module should be compatible with older repos [validation pending]

changes in the cubicweb.dbapi module in 3.19 make it incompatible with pre-3.19 remote repos.

prioritynormal
typebug
done in3.19.2
load0.250
load left0.000
closed by#465d8151b92d [dbapi] allow talking to a pre-3.19 remote repository
patch[dbapi] allow talking to a pre-3.19 remote repository [applied]