cubicweb-medicalexp #5338024 subject_age → age_of_subject [in-progress]

For the sake of consistency, what about changing in the schema all occurrences of:
subject_age
into:
age_of_subject

prioritynormal
typeenhancement
done in<not specified>
closed by<not specified>
patch[schema] rename "subject_age" to "age_of_subject" (closes #5338024) [in-progress]