cubicweb #716055 problems with 3.5 -> 3.6 migration [resolved]

when migrating from 3.5 to 3.6, it would be better if cubes would keep working, which is not the case when they are using functions from cubicweb.utils that changed heavily: some functions were moved to logilab-common, but no compatibility wrappers were made available en 3.6.

prioritynormal
typebug
done in3.6.1
load0.200
load left0.000
closed by#7c41eea7fc30 restore 3.5 compat for date functions moved to lgc.date in 3.6 (closes #716055)