cubicweb #9720390 cubicweb < 3.21 broken by yams >= 0.42 [validation pending]

Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/logilab/common/", line 443, in testfile
options=self.options, outstream=sys.stderr)
File "/usr/lib/python2.7/dist-packages/logilab/common/", line 759, in __init__
File "/usr/lib/python2.7/unittest/", line 77, in __init__
self.module = __import__(module)
File "", line 33, in <module>
from cubicweb.schema import (
File "/opt/local/dlaxalde/cubicweb/.tox/cubicweb/local/lib/python2.7/site-packages/cubicweb/", line 39, in <module>
from yams.reader import (CONSTRAINTS, PyFileReader, SchemaLoader,
ImportError: cannot import name obsolete

Yams declares the breaks for cubicweb < 3.21 in debian/control but there's nothing in so that cubicweb 3.20 (at least) is unusable if installed by pip as the latter would pull the latest yams by default.

done in3.20.13
load left0.000
closed by#9c0fac5028c0 [pkg] Yams >= 0.42 breaks CubicWeb < 3.21
patch[pkg] Yams >= 0.42 breaks CubicWeb < 3.21 [applied]